Which Smart TVs are you supporting?

At the moment we have an app for Samsung and LG Smart TVs from 2012 to 2015. The app can work on newer Samsung models if the hardware is supporting the functions of the app.  We also support Android smart TVs with Android 5.0.  

 



 

 

Comments