Which Android devices does Magine TV support?

To use Magine TV in your Android device you need to have an unmodified Android version 4.0.3 or higher. We support the major brands in the actual market like Samsung, LG, HTC , Sony, Google Nexus. We cannot support every device because all the new Android phones have a different software, but we are working hard every day for having all the new devices supported by Magine TV.

Google Play

You can download the app at Google Play.

Amazon Appstore for android

You can find our app by searching for "Magine Tv" in the search field, and download it at Amazon Appstore for android Amazon Appstore

Amazon supported devices

Fire HDX 8.9 WiFi (3rd Gen).
Fire HDX 8.9 WAN (3rd Gen).
Fire HDX 7 WiFi (3rd Gen).
Fire HDX 7 WAN (3rd Gen).
Kindle Fire HD 7 (3rd Gen).
Fire HD 8.9 WAN (2nd Gen).
Fire HD 8.9 Wifi (2nd Gen).
Kindle Fire HD 7 (2nd Gen).
Kindle Fire (2nd Gen)

 

Comments